All Systems Operational

About This Site

Welcome to SafetyCulture's system status – status updates for SafetyCulture’s services and components.

SafetyCulture Operational
90 days ago
99.95 % uptime
Today
Inspections Operational
90 days ago
99.95 % uptime
Today
Issues Operational
90 days ago
99.97 % uptime
Today
Sensors Operational
90 days ago
99.63 % uptime
Today
Assets Operational
90 days ago
99.98 % uptime
Today
Analytics Operational
90 days ago
100.0 % uptime
Today
Public Library Operational
90 days ago
100.0 % uptime
Today
Heads Up Operational
90 days ago
100.0 % uptime
Today
Public API Operational
90 days ago
99.99 % uptime
Today
Mobile App Operational
90 days ago
99.93 % uptime
Today
Web Platform Operational
90 days ago
100.0 % uptime
Today
Training Operational
90 days ago
99.94 % uptime
Today
Actions Operational
90 days ago
99.97 % uptime
Today
Integrations Operational
90 days ago
99.99 % uptime
Today
Website Operational
90 days ago
100.0 % uptime
Today
SHEQSY Operational
90 days ago
100.0 % uptime
Today
SHEQSY App Operational
90 days ago
100.0 % uptime
Today
SHEQSY Dashboard Operational
90 days ago
100.0 % uptime
Today
SHEQSY API's Operational
90 days ago
100.0 % uptime
Today
SHEQSY 24/7 Monitoring Operational
90 days ago
100.0 % uptime
Today
SHEQSY Satellite Devices Operational
90 days ago
100.0 % uptime
Today
SHEQSY Notifications Operational
90 days ago
100.0 % uptime
Today
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Major outage
Partial outage
No downtime recorded on this day.
No data exists for this day.
had a major outage.
had a partial outage.
Past Incidents
Apr 26, 2024

No incidents reported today.

Apr 25, 2024

No incidents reported.

Apr 24, 2024
Resolved - This incident has been resolved.
Apr 24, 05:15 UTC
Monitoring - We have identified the issue and the problem appears to be mitigated at this stage. Our engineering teams are working on a permanent resolution.
Apr 24, 05:07 UTC
Update - We are currently aware of an issue where Inspections are not loading in the AU region. Our engineering teams are investigating.
Apr 24, 04:46 UTC
Investigating - We are currently aware of an issue where Inspections are not loading in the AU region. Our engineering teams are investigating.
Apr 24, 04:42 UTC
Apr 23, 2024

No incidents reported.

Apr 22, 2024

No incidents reported.

Apr 21, 2024
Resolved - This incident has been resolved. Kindly refresh your page/restart the app in order to load the training tab.
Apr 21, 23:37 UTC
Investigating - We are aware of the issue with the training tab not loading. We are currently investigating the issue.
Apr 21, 22:47 UTC
Apr 20, 2024

No incidents reported.

Apr 19, 2024

No incidents reported.

Apr 18, 2024

No incidents reported.

Apr 17, 2024

No incidents reported.

Apr 16, 2024
Resolved - This incident has been resolved.
Apr 16, 03:32 UTC
Monitoring - Sensors are coming back online. We will continue to monitor this closely.
Apr 16, 02:10 UTC
Investigating - We are aware of the issue where some sensors are currently offline. Our engineers are currently investigating
Apr 16, 00:27 UTC
Apr 15, 2024

No incidents reported.

Apr 14, 2024

No incidents reported.

Apr 13, 2024

No incidents reported.

Apr 12, 2024

No incidents reported.