Inspection visibility delayed
Incident Report for SafetyCulture US
Resolved
This incident has been resolved. We thank you again for your patience and understanding through this incident.
Posted Jul 01, 2020 - 10:51 AEST
Update
We are seeing a reduction in the delay. We appreciate your patience and understanding whilst we continue to investigate this issue.
Posted Jul 01, 2020 - 10:23 AEST
Update
We are continuing to investigate this issue.
Posted Jul 01, 2020 - 09:50 AEST
Investigating
We are aware some customers may be experiencing delays in the visibility of their inspections. All data is saved to our servers and we are investigating this delay.
Posted Jul 01, 2020 - 09:15 AEST
This incident affected: iAuditor Web Platform, iAuditor Public API and iAuditor Platform (iAuditor iOS, iAuditor Android).