Mobile app not syncing
Incident Report for SafetyCulture
Resolved
This incident has been resolved.
Posted Mar 21, 2024 - 12:33 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 21, 2024 - 12:26 UTC
Investigating
We are currently aware of an issue in the latest release of SafetyCulture for mobile users causing the Home page to not load. Our engineering teams are investigating.
Posted Mar 21, 2024 - 12:24 UTC
This incident affected: SafetyCulture (Mobile App).